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Purpose:
This manual provides user information for the Executive Level Metrics (ELM) tool set, previously known as the ‘7-Up Metrics Executive’. (Revised 04/2003)
The tool is designed for maximum flexibility so as to support changes in the metrics as they are recommended and approved by the SEPG Metrics Working Group. In this release, the tool can produce the required charts, print a metric report, which includes a description and analysis statement for each chart, and can provide weighted average projections (should that method be appropriate and selected for use by the analyst) or manually input projected values. 

General Description:
The ELM tool is set up so that each project can enter monthly updates and produce up to a 12 month ‘window’ of data (i.e., 6 months of actual and 6 months of projections) for each of the seven defined metric charts.  Quantitative information is entered into an EXCEL file, while descriptive information is added to the corresponding WORD file.  The EXCEL and WORD files are dynamically linked for automatic transfer of data.

The user enters descriptive and analysis information into the WORD file for each chart and the results are output for color printing. Historical data is retained within the Excel tables as an archive for data entered each month [up to 48 months, expandable to the project’s needs].

What’s New in Version 5.0:
· The Earned Value and Project Schedule Milestones have been divided into separate charts per previous ARA-1 request.

· The Document Cycle Time metric has been deleted per previous ARA-1 request.

· The ability to track performance against projections has been added to all measures per previous ARA-1 request.

· The column placement bug in the “Milestones” Metric has been fixed.

· The cell referencing problem, and resulting errors, in the Requirements Metric has been fixed.

· The “Weighted Average” formulas have been corrected.

· Hard page breaks were added in the Word file to facilitate proper pagination of the report.

· Errors and clarity issues were fixed in the metric descriptions and charts for several of the measures.
Tips for converting from previous versions:

· The tool will transfer data from the 4.2 version by executing the transfer Visual Basic module under Tools.  If you are using an earlier version, you must first convert to the 4.2 version (Note:  Version 4.2 contains a Visual Basic module that will transfer data from all previous versions).  If you are using version 4.3 please contact the MWG for special assistance.

· After the data has been transferred, the scale for the Y axis on most charts will need to be set.  I found that having a copy of the last report in front of me made the process relatively painless.

· The static data boxes on the charts will need to be updated with your project data.

· Since projection data is transferred as well, you must refresh the metrics that are using automated weighted average projection.  This is done by simply selecting weighted average projection under Tools, for each measure using that method.  Metrics that are using manually entered projections are not effected by the transfer.

System Resource Requirements:

SYSTEM:
· P-200 MMX or greater, 32 MB RAM or greater, 17” (min) monitor recommended 

· Color Printer (laser or ink jet)

· Hard Disk storage requirements are not anticipated to be a problem.

Each project will need the ability to store the WORD files generated each month as separate files in case one needs to recall it.  However, a complete set of the basic historical data will be retained from month to month within the EXCEL file as it is updated.

SOFTWARE:
· Microsoft Windows 95

· Microsoft Office 97 (MWG can provide the files for earlier versions upon request)

COMPETENCIES:
A basic knowledge of WINDOWS, EXCEL, and WORD applications is assumed for using this tool.  It is also useful to have experience and/or training in statistical analysis.  Furthermore, the analyst must be familiar with the project being tracked, as well as the general approach to software/systems development.

The MWG provides formal training on the use of the ELM tool set.  We strongly encourage completion of the training course prior to using the tool set.

Installation:

The ELM tool set consists of the following files:

a.  7-upv50.xls

b.  7-upv50.doc

c.  7-upv50m.dot

d.  Non-operational documentation:  guide50.doc (a detailed description of each metric), useman51.doc (this document -- the user manual)

NOTE:  In order for the tool to operate correctly, particular attention should be placed on correct naming of the required directories, and placement of the files.

PROCEDURE:
1.
Create the following directory, and subdirectories, on your local hard disk drive (C:):

a.  C:\7-up

b.  C:\7-up\archive\

c.  C:\7-up\history\

d.  C:\7-up\masters\

2.
Load the Word template Visual Basic module file named 7-upv50m.dot into the C:\MSOFFICE\STARTUP directory (or folder).

NOTE: The exact path may vary with the installation of the applications software.  Consult your system administrator (or the Metrics Working Group) if you are in doubt, or the ‘Prepare for Archive’ option does not appear under the Tools pull down menu.  It’s a rather simple fix.

This ‘dot’ file contains a visual basic macro that will allow you to archive the monthly report (more on that later).  It is activated from the Tools menu of Word, select ‘Prepare for Archive’.

3.
Load the two application files (7-upv50.xls and 7-upv50.doc) into the C:\7-up\ directory.  This is the working directory for the ELM tool.
4.
The MWG suggests that you maintain copies of the tool on your local hard disk drive, so that in the event the working copy becomes unusable, a quick backup copy is available.  Load a copy of all ELM files (there are 5 files in total) into the C:\7-up\masters\ directory.  As new versions of the tool are released, we suggest that you move the master set from the previous version into the historical data directory -- C:\7-up\history\.

5.
The C:\7-up\archive\ directory is designed to hold the completed monthly reports.  The monthly report is the file: 7-upv50.doc, and must be saved using the Save As command from the File menu.  It is important to use the Prepare for Archive Visual Basic module from the Word Tools menu after the report has been completed, and saved (within the C:\7-up\ directory).  The Visual Basic module will disable all of the links with the Excel tool, and prevent it from self modifying.  

After running the Visual Basic module, use the Save As command, and select the location as C:\7-up\archive\, use the appropriate report file name.  Guidance on the naming conventions follows:

[Note: the MWG suggests the following file naming convention to facilitate collection of the data.] 

ABcdMMyy.doc     [This applies only to the completed report which is archived to the C:\7-up\archive directory.  Capitalization is used to help differentiate between the codes, it is not required in practice.]

AB = Project name code, assigned by the MWG;

cd = Local code, a required two character code, enter as a place holder if no

     local requirement exists;

MM = Date of the report, enter two digit month (01-12);

yy = Year of the report, enter two digit year (e.g., 98 = 1998)

Tool Usage Procedure:
Tool Initialization (first use only):
1. Launch the Excel application from the Windows 95 Programs Menu.

2. Working in Excel, open the 7-upv50.xls file found in the C:\7-up directory.

3. The first step is to adjust the timeline to be consistent with your first reporting month.  The date in column “G” is the current data month, and represents the date of the most current data for this report.  The date can be adjusted by selecting “Next Month Data Entry” from the Tools menu.  The timeline will advance one month each time the selection is made.

4. Now set the date for the archive section.  From the Tools menu select “Set Archive Date”.

5. From the Tools menu select “Clear Chart Data”, this will clear the sample data from the file.

6. From the Tools menu select “Clear Archive Data”, this will clear the sample data from the archive section of the file.

7. You are now ready to enter data.  These steps will not be repeated for subsequent reporting months.  During the first usage, data for the past 6 months should be entered both in the charting area and in the archive area.

Data Transfer:
If you are transferring data from a previous version, select ‘Transfer Data’ from the Tools menu.  Both versions of the tool should be resident in the same directory (working directory [C:\7-up]).  This tool will transfer data from version 4.2 only.  If you need help with transfers from other versions please contact the MWG.

Monthly Data Entry:
1. Open both the Excel (.xls) and the Word (.doc) files that are located in the C:\7-up\ directory.  Open the Excel file first.  It will speed up the process, and do away with an annoying execution of the startup Visual Basic module (seven times) if done in the reverse order.  This practice should be followed whenever the tool is being used in the future.  Minimize the Word application while performing steps 2 and 3.

2. Follow steps 1, 2, and 3 from the procedure above.

3. Enter the current data in column “G”.

[NOTE:  While working in Excel, do not enter data in red fields.  These fields contain formulas or reference locations and if altered will adversely effect the function of the tool.]

Projections and Adjustments:
1. Select Manual Projection, or Weighted Average Projection for each metric.  The selection is made while in the data sheet for each metric, under the Tools menu.  Manual Projection allows the user to enter data for the next six months (predictive).  The data entry fields will be blue in color.  If weighted average is selected the computer will generate data for the next six months, and the fields will be red in color.  Typically, the weighted average method is not appropriate since it simply evaluates the past trend, weighing recent performance more heavily, and then performs a linear extrapolation.  The weighted average formula is a modified version of the “Simpson’s Rule”, for prediction of the most likely trend.

2. After you complete the data entry, go to the related metric “chart tab” to enter information contained in the static data boxes.  Use the zoom feature in Excel to increase the chart size to 100% for editing purposes.  The chart size is normally set to 50% for standard viewing (the entire chart is visible at one time), but the static data information does not display correctly.  Zooming to 100% will correct the problem, and allow you to edit.  It is recommended that after editing is complete, return the chart size to 50%.  Do this for all metric charts, as required.  Double clicking on the static data will allow you to edit.  A single click, elsewhere on the chart, will close the editing window.
3. Set the “Y” axis.  The axis should be set for maximum spacing of columns and lines.  To do this, first review the data and determine the boundaries (highest and lowest values to be charted).  Double click the “Y” axis and set the scale to be consistent with your data.  We suggest the following method:  Set the MINIMUM value at approximately 10% below the low end of your data (round to a number divisible by ten), and the MAXIMUM value approximately 10% above the high end of your data (rounding as above).  Use the following formula to calculate the MAJOR UNIT value:  (MAX-MIN)/10 this will give you ten tick marks of resolution (ELM standard).  Set the MINOR UNIT value at 1 (one).

[NOTE:  For the following steps, you will need to minimize the Excel application, and maximize the Word application.]

In the Word file, complete the following setup operations:


[NOTE:  There are seven (7) pages to the report, and each page may



  require some or all of the following information to be



  entered during setup.]

1. Enter the project name.

2. Enter the report date (each month you will need to do this).

3. Verify that the ‘Metric Descriptions’ for each metric are consistent with your data and presentation.  The descriptions are intended to be standard, but slight variations to the metrics may require wording changes.  In particular, the Technical Performance metric, which is intended to be selected, and designed, by the project [Note: If substantial differences, then seek approval from the MWG].

4. Enter into the “Analysis’ section, any explanations of the six months of historical information regarding trends, and deviations of ‘actuals’ from ‘plans’, inaccurate projections, etc.

5. Repeat steps 1 through 4, as required, for each metric.  It is a good practice to save after each one is complete.

6. SAVE the information in the Word and Excel files. 

IMPORTANT:  DO NOT CHANGE THE FILE NAMES WHILE WORKING WITH THE DATA AND THE REPORT INFORMATION.  THESE ARE THE WORKING FILES, AND WILL KEEP THE DEFAULT NAMES TO MAINTAIN THE INTEGRITY OF THE LINKS.

Monthly Updating:
· Follow the process, outlined above, to open the working files.

· In Excel, select the Tools/Next Month Data Entry Visual Basic module to move all of the data one month to the left, and open the current month (at the center of the chart) for new data entry. 

· Enter data per the above process.

[Note: The second chart for each metric (with an “AC” suffix) plots the data in the archive section of the spreadsheet.  It is intended that we will see the development of standard statistical curves over time, and in the future we can use the information to predict performance.]
· When all data has been input, and the analysis completed, save both the Word and Excel files.  If the charts in the Word file have not updated themselves, you can force an update by closing down the Word file and then restarting it.  This is the 7-upv50.doc file (save before closing the file).  Another method is to use the Links utility under the Edit menu.  Select all of the links, and then click Update Now.

· Now that both files contain the correct information, and have been saved.  Select the “Prepare for Archive” Visual Basic module, under Tools, to prepare the Word file for archiving in the:   C:\7-up\archive\ directory.

Printing the Report:
1.
The metric report will print from Word.  Check the pagination, and make


corrections as necessary to ensure the report format is correct.

2.
It is intended that the report be printed in color.  If a color printer


is not available to you, contact the MWG.


1. 
2. 
Tool Updates:

As tool revisions become available, following a Change Request process managed by the MWG, they will be posted to the FAST Tool (http://fast.faa.gov/).  Simply select metrics under specialty functions, processes and guidance.  The tool will provide automated transfer of data from version to version.


Appendix A

ELM Tool Nuances

General:
· MACRO VIRUS PROTECTION:  These tools contain visual basic modules (macros) which will be identified as potential threats to your computer by certain software packages (Excel included).  These macros are essential to the operation of the ELM tool set, therefore must be enabled.  If identified by Excel, select the <Enable> option, or the detection feature can be disabled by selecting Tools, then Options, then <General>, then deselect “Macro virus protection”, then select <OK>.

· The ‘p’ prefix to a data type designates it as a ‘projected’ value.

· All charts should show six months of actuals, and six months of projections.

· Visual Basic modules are launched from the Tools pull down menus for both Word and Excel.

· Field colors:  Red -- Don’t enter data in a red field, Blue -- Denotes a manual projection, Yellow -- Normal data entry area.

Specific:

1)
Contractor Earned Value
· The chart contains a static data box which must be updated manually.

· The CPI and SPI values are calculated in the spreadsheet, but must be manually entered into the static data box.

2)
Project Milestones
· None.

3)
Requirements Stability
· The chart contains a static data box which must be updated manually.

· The cumulative percent change can exceed 100%.

· “A” Level = System

· “B” Level = Software

4)
Product Quality
· The chart contains a static data box which must be updated manually.

5)
Software Progress
· The chart contains a static data box which must be updated manually.

· We advise that you read the metric Guideline closely for this one.  This is software implementation progress, and size.  It can be tricky!

6)
Benefits to Cost Ratio
· This one is straight forward.

7)
Technical Performance
· We suggest one technical issue per chart.  If you have more than one technical issue to track, please contact the MWG for assistance.

· The metric description is to be written by each project for the measure selected.  It will need to be entered into the WORD file (7-upv50.doc), replacing the generic text that comes with the tool.

